<!DOCTYPE html>
<html lang="en-US">
<head>
	<title>Asheville Downtown Association to hold cleanup day April 18 | Mountain Xpress</title>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
	<meta name="theme-color" content="#642D91">
	<meta property="og:site_name" content="Mountain Xpress">
	<meta property="og:url" content="http://mountainx.com/blogwire/asheville-downtown-association-to-hold-cleanup-day-april-18/">
	<meta property="og:type" content="website">
	<meta property="og:title" content="Mountain Xpress">
	<meta property="og:image" content="http://mountainx.com/wp-content/themes/mx/img/logo-default.svg">
	<meta property="og:description" content="Asheville and Western North Carolina News | Local Matters - Arts, Food, Music and Movies">
	<meta name="description" content="Asheville and Western North Carolina News | Local Matters - Arts, Food, Music and Movies">
	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:site" content="@mxnews">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://mountainx.com/xmlrpc.php">
	<link rel="shortcut icon" href="https://mountainx.com/wp-content/themes/mx/favicon.ico" />
		<script type="text/javascript">
		var ajaxurl = 'https://mountainx.com/wp-admin/admin-ajax.php';
		</script>
		<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mountain Xpress &raquo; Feed" href="https://mountainx.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mountain Xpress &raquo; Comments Feed" href="https://mountainx.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Mountain Xpress &raquo; iCal Feed" href="https://mountainx.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Mountain Xpress &raquo; Asheville Downtown Association to hold cleanup day April 18 Comments Feed" href="https://mountainx.com/blogwire/asheville-downtown-association-to-hold-cleanup-day-april-18/feed/" />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://mountainx.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_icons-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css?ver=4.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.1.0/css/font-awesome.css' type='text/css' media='screen' />
<link rel='stylesheet' id='udefault-css'  href='https://mountainx.com/wp-content/plugins/ultimate-wp-query-search-filter/themes/default.css?ver=all' type='text/css' media='all' />
<link rel='stylesheet' id='mx-bootstrap-css'  href='https://mountainx.com/wp-content/themes/mx/css/bootstrap.min.css?ver=3.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='mx-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.1.0/css/font-awesome.min.css?ver=4.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mx-custom-font-css'  href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C400italic%2C700%2C700italic%2C900&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='mx-style-css'  href='https://mountainx.com/wp-content/themes/mx/style.css.php?ver=1.1.58' type='text/css' media='all' />
<link rel='stylesheet' id='newsletter-css'  href='https://mountainx.com/wp-content/plugins/newsletter/style.css?ver=5.7.1' type='text/css' media='all' />
<script type='text/javascript' src='https://mountainx.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://mountainx.com/wp-includes/js/jquery/jquery-migrate.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gglcptch_vars = {"nonce":"f200f9554c"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mountainx.com/wp-content/plugins/google-captcha/js/script.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://mountainx.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var social_connect_data = {"wordpress_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://mountainx.com/wp-content/plugins/social-connect/media/js/connect.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://mountainx.com/wp-content/themes/mx/js/bootstrap.min.js?ver=3.3.4'></script>
<script type='text/javascript' src='https://mountainx.com/wp-content/themes/mx/js/bootstrap-hover-dropdown.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://mountainx.com/wp-content/themes/mx/js/jquery.mobile.touch.min.js?ver=1.4.5'></script>
<script type='text/javascript' src='https://mountainx.com/wp-content/themes/mx/js/jquery.ba-dotimeout.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://mountainx.com/wp-content/themes/mx/js/custom.js?ver=1.0.17'></script>
<link rel='https://api.w.org/' href='https://mountainx.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mountainx.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mountainx.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Air quality forecast for Asheville, Wednesday, Feb. 20: Moderate (YELLOW)' href='https://mountainx.com/blogwire/air-quality-forecast-for-asheville-wednesday-feb-20-moderate-yellow/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel="canonical" href="https://mountainx.com/blogwire/asheville-downtown-association-to-hold-cleanup-day-april-18/" />
<link rel='shortlink' href='https://mountainx.com/?p=733463' />
<link rel="alternate" type="application/json+oembed" href="https://mountainx.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmountainx.com%2Fblogwire%2Fasheville-downtown-association-to-hold-cleanup-day-april-18%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mountainx.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmountainx.com%2Fblogwire%2Fasheville-downtown-association-to-hold-cleanup-day-april-18%2F&#038;format=xml" />

<style>
@media (min-width: 1px)
      and
  (max-width: 1024px) {
.scroll-back-to-top-wrapper {
    position: fixed;
	opacity: 0;
	visibility: hidden;
	overflow: hidden;
	text-align: center;
	z-index: 99999999;
    background-color: #777777;
	color: #eeeeee;
	width: 50px;
	height: 48px;
	line-height: 48px;
	right: 30px;
	bottom: 30px;
	padding-top: 2px;
	border-top-left-radius: 10px;
	border-top-right-radius: 10px;
	border-bottom-right-radius: 10px;
	border-bottom-left-radius: 10px;
	-webkit-transition: all 0.5s ease-in-out;
	-moz-transition: all 0.5s ease-in-out;
	-ms-transition: all 0.5s ease-in-out;
	-o-transition: all 0.5s ease-in-out;
	transition: all 0.5s ease-in-out;
}
.scroll-back-to-top-wrapper:hover {
	background-color: #888888;
  color: #eeeeee;
}
.scroll-back-to-top-wrapper.show {
    visibility:visible;
    cursor:pointer;
	opacity: 1.0;
}
.scroll-back-to-top-wrapper i.fa {
	line-height: inherit;
}
.scroll-back-to-top-wrapper .fa-lg {
	vertical-align: 0;
}
}
</style><link rel='stylesheet' id='social_connect-css'  href='https://mountainx.com/wp-content/plugins/social-connect/media/css/style.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://mountainx.com/wp-includes/css/dashicons.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css'  href='https://mountainx.com/wp-includes/css/jquery-ui-dialog.css?ver=4.9.8' type='text/css' media='all' />
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
	var vpw = document.documentElement.clientWidth;
	var takeoverLeft, takeoverRight, mobileTakeover, mobileTakeoverFullscreen;

	if (vpw < 768) {
		var mobileTakeover = googletag.defineSlot('/1070965/mx-mobile-takeover-home', [320, 60], 'mx-ad-mobile-takeover').addService(googletag.pubads());
		var mobileTakeoverFullscreen = googletag.defineSlot('/1070965/mx-mobile-takeover-fullscreen-home', [360, 640], 'mx-ad-mobile-takeover-fullscreen').addService(googletag.pubads());
		googletag.defineSlot('/1070965/mx-mobile-leaderboard-home', [320, 100], 'mx-ad-mobile-leaderboard').addService(googletag.pubads());
		googletag.defineSlot('/1070965/mx-mobile-premium-box-home', [300, 250], 'mx-ad-mobile-premium-box').addService(googletag.pubads());
	} else if (vpw < 992) {
		googletag.defineSlot('/1070965/mx-leaderboard-home', [728, 90], 'mx-ad-leaderboard').addService(googletag.pubads());
		googletag.defineSlot('/1070965/mx-premium-box-home', [300, 250], 'mx-ad-tablet-premium-box').addService(googletag.pubads());
		googletag.defineSlot('/1070965/mx-standard-box-home', [300, 250], 'mx-ad-tablet-standard-box').addService(googletag.pubads());
		googletag.defineSlot('/1070965/mx-premium-banner-home', [540, 120], 'mx-ad-premium-banner').addService(googletag.pubads());
	} else {
		googletag.defineSlot('/1070965/mx-leaderboard-home', [728, 90], 'mx-ad-leaderboard').addService(googletag.pubads());
		googletag.defineSlot('/1070965/mx-pencil-home', [1200, 300], 'mx-ad-pencil').addService(googletag.pubads());
		googletag.defineSlot('/1070965/mx-premium-banner-home', [540, 120], 'mx-ad-premium-banner').addService(googletag.pubads());
		googletag.defineSlot('/1070965/mx-premium-box-home', [300, 250], 'mx-ad-premium-box').addService(googletag.pubads());
		googletag.defineSlot('/1070965/mx-standard-box-home', [300, 250], 'mx-ad-standard-box').addService(googletag.pubads());
	}
	googletag.pubads().enableSingleRequest();
	googletag.enableServices();
	googletag.pubads().addEventListener('slotRenderEnded', function(event) {
		
		if (event.slot === takeoverLeft) {
			if (event.isEmpty) {
				hideTakeoverLeft();
			} else {
				hoverTakeoverLeft();
			}
		}

		if (event.slot === takeoverRight) {
			if (event.isEmpty) {
				hideTakeoverRight();
			} else {
				hoverTakeoverRight();
			}
		}

		if (event.slot === mobileTakeover) {
			if (event.isEmpty) {
				hideMobileTakeover();
			} else {
				loadMobileTakeover();
			}
		}
		
		if (event.slot === mobileTakeoverFullscreen) {
			if (event.isEmpty) {
				hideMobileTakeoverFullscreen();
			} else {
				loadMobileTakeoverFullscreen();
			}
		}
	});
});
</script>
<!--[if lt IE 9]>
	<script src="https://mountainx.com/wp-content/themes/mx/js/html5shiv.js"></script>
	<script src="https://mountainx.com/wp-content/themes/mx/js/respond.min.js"></script>
<![endif]-->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-1544161-1', 'mountainx.com');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');
</script>
</head>
<body class="mx_blogwire-template-default single single-mx_blogwire postid-733463 group-blog tribe-theme-mx page-template-single-mx_blogwire-php">
<div id="fb-root"></div>
<div class="modal fade" id="loginModal" tabindex="-1" role="dialog" aria-hidden="true"><div class="modal-dialog"><div class="modal-content"></div></div></div>
<div id="mx-wrap">
	<div id="mx-header">
	<div class="container hidden-xs">
		<ul class="nav nav-pills pull-left">
			<li class=""><a href="https://mountainx.com/classifieds/">Classifieds</a></li>
			<li class=""><a href="https://asheville.scenethink.com/mountainxpress/cal">Calendar</a></li>
			<li class=""><a href="http://asheville.scenethink.com/clubland/cal">Clubland</a></li>
			<li class="nav-divider"></li>
			<!--potential to add visible-lg as class but do not know what it does :P-->
			<li class=""><a href="https://mountainx.com/guide/best-of-wnc-2018/"><i class="fa fa-trophy"></i> Best of WNC</a></li>
			<li class=""><a href="http://mountainx.com/guide/eats-drinks-2018/"><i class="fa fa-cutlery"></i> Eats &amp; Drinks</a></li>
			<li class="hidden-sm hidden-md"><a href="http://givelocalguide.org/" target="_blank" style="padding-left:38px;"><i class="fa fa-thumbs-up"></i> Give Local Guide</a></li>
		</ul>
		<div class="pull-right mx-user">
		<a class="btn mx-bg-default" data-toggle="modal" data-target="#loginModal" href="https://mountainx.com/wp-admin/admin-ajax.php?action=load_login_modal">Login</a><a class="btn mx-bg-default" href="https://mountainx.com/wp-login.php?action=register">Register</a><a href="https://mountainx.com/?theme=dark" class="btn bulb" title="Turn off the lights"><i class="fa fa-lightbulb-o"></i></a>		</div>
	</div>
		<div class="mx-hr hidden-xs"></div>
		<div class="container">
			<!-- AD Leaderboard -->
			<div id="mx-ad-leaderboard" class="pull-right hidden-xs" style="width:728px; height:90px;">
			<script type='text/javascript'>
				googletag.cmd.push(function() { googletag.display('mx-ad-leaderboard'); });
			</script>
			</div>
			<object type='image/svg+xml' data='https://mountainx.com/wp-content/themes/mx/img/logo-default.svg' class='logo pull-left visible-md visible-lg'></object>		</div>
	</div>
	
	<div id="mx-nav" class="navbar navbar-default mx" role="navigation">
		<div class="mx-nbt mx-bg-home"></div>
		<div class="container">
			<div class="navbar-header">
				<button type="button" class="navbar-toggle btn-lg" data-toggle="collapse" data-target="#mx-nav-primary"><i class="fa fa-bars"></i></button>
				<button type="button" class="navbar-toggle btn-lg" data-toggle="collapse" data-target="#mx-nav-search"><i class="fa fa-search"></i></button>
				<button type="button" class="navbar-toggle btn-lg" data-toggle="collapse" data-target="#mx-nav-account"><i class="fa fa-user"></i></button>
<object type='image/svg+xml' data='https://mountainx.com/wp-content/themes/mx/img/logo-mobile.svg' id='mx-nav-logo' class=''></object>			</div>
			
			<div id="mx-nav-primary" class="collapse navbar-collapse navbar-left">
				<div class="visible-xs">
					<div class="btn-group btn-group-justified btn-group-sm">
						<a href="https://mountainx.com/clubland/" class="btn" role="button">Clubland <i class="fa fa-music"></i></a>
						<a href="https://mountainx.com/calendar/" class="btn" role="button">Calendar <i class="fa fa-calendar"></i></a>
						<a href="https://mountainx.com/classifieds/" class="btn" role="button">Classifieds <i class="fa fa-star-o"></i></a>
						<a href="https://mountainx.com/guides/" class="btn" role="button">Guides <i class="fa fa-book"></i></a>
					</div>
				</div>
<ul id="menu-main-navigation" class="nav navbar-nav"><li id="menu-item-arts" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-92345 dropdown"><a href="https://mountainx.com/arts/" data-hover="dropdown" data-toggle="dropdown" class="mx-menu-item dropdown-toggle">Arts</a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-92346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92346"><a href="https://mountainx.com/arts/art-news/">Art News</a></li>
	<li id="menu-item-486674" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-486674"><a href="https://mountainx.com/arts/comedy/">Comedy</a></li>
	<li id="menu-item-92347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92347"><a href="https://mountainx.com/arts/craft/">Craft</a></li>
	<li id="menu-item-92348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92348"><a href="https://mountainx.com/arts/dance/">Dance</a></li>
	<li id="menu-item-381354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-381354"><a href="https://mountainx.com/arts/fashion/">Fashion</a></li>
	<li id="menu-item-92350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92350"><a href="https://mountainx.com/arts/literature/">Literature</a></li>
	<li id="menu-item-92351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92351"><a href="https://mountainx.com/arts/music/">Music</a></li>
	<li id="menu-item-92352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92352"><a href="https://mountainx.com/arts/performance-art/">Performance Art</a></li>
	<li id="menu-item-384274" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-384274"><a href="https://mountainx.com/arts/theater/">Theater</a></li>
	<li id="menu-item-92354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92354"><a href="https://mountainx.com/arts/visual-art/">Visual Art</a></li>
</ul>
</li>
<li id="menu-item-news" class="menu-item menu-item-type-taxonomy menu-item-object-category current-mx_blogwire-ancestor current-menu-parent current-mx_blogwire-parent menu-item-has-children menu-item-92370 dropdown"><a href="https://mountainx.com/news/" data-hover="dropdown" data-toggle="dropdown" class="mx-menu-item dropdown-toggle">News</a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-92372" class="menu-item menu-item-type-taxonomy menu-item-object-category current-mx_blogwire-ancestor current-menu-parent current-mx_blogwire-parent menu-item-92372"><a href="https://mountainx.com/news/community-news/">Community News</a></li>
	<li id="menu-item-92371" class="menu-item menu-item-type-taxonomy menu-item-object-category current-mx_blogwire-ancestor current-menu-parent current-mx_blogwire-parent menu-item-92371"><a href="https://mountainx.com/news/business/">Business</a></li>
	<li id="menu-item-92373" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92373"><a href="https://mountainx.com/news/environment/">Environment</a></li>
	<li id="menu-item-92374" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92374"><a href="https://mountainx.com/news/local-government/">Local Government</a></li>
	<li id="menu-item-92375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92375"><a href="https://mountainx.com/news/politics-elections/">Politics &#038; Elections</a></li>
</ul>
</li>
<li id="menu-item-food" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-92355 dropdown"><a href="https://mountainx.com/food/" data-hover="dropdown" data-toggle="dropdown" class="mx-menu-item dropdown-toggle">Food</a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-92358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92358"><a href="https://mountainx.com/food/food-news/">Food News</a></li>
	<li id="menu-item-92356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92356"><a href="https://mountainx.com/food/beer/">Beer &#038; Cider</a></li>
	<li id="menu-item-92357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92357"><a href="https://mountainx.com/food/coffee-tea/">Coffee &#038; Tea</a></li>
	<li id="menu-item-92359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92359"><a href="https://mountainx.com/food/wine-spirits/">Wine &#038; Spirits</a></li>
</ul>
</li>
<li id="menu-item-living" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-92360 dropdown"><a href="https://mountainx.com/living/" data-hover="dropdown" data-toggle="dropdown" class="mx-menu-item dropdown-toggle">Living</a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-381355" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-381355"><a href="https://mountainx.com/living/farm-garden/">Farm &#038; Garden</a></li>
	<li id="menu-item-427390" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-427390"><a href="https://mountainx.com/living/outdoors/">Outdoors</a></li>
	<li id="menu-item-92362" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92362"><a href="https://mountainx.com/living/spirituality/">Spirituality</a></li>
	<li id="menu-item-484278" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-484278"><a href="https://mountainx.com/living/sustainability/">Sustainability</a></li>
	<li id="menu-item-381352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-381352"><a href="https://mountainx.com/living/wellness/">Wellness</a></li>
	<li id="menu-item-385097" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-385097"><a href="https://mountainx.com/volunteering/">Volunteering</a></li>
</ul>
</li>
<li id="menu-item-movies" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-92364 dropdown"><a href="https://mountainx.com/movies/" data-hover="dropdown" data-toggle="dropdown" class="mx-menu-item dropdown-toggle">Movies</a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-92365" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92365"><a href="https://mountainx.com/movies/movie-news-previews/">Movie News &#038; Previews</a></li>
	<li id="menu-item-381318" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-381318"><a href="/movies/reviews">Movie Reviews</a></li>
</ul>
</li>
<li id="menu-item-opinion" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-92376 dropdown"><a href="https://mountainx.com/opinion/" data-hover="dropdown" data-toggle="dropdown" class="mx-menu-item dropdown-toggle">Opinion</a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-92377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92377"><a href="https://mountainx.com/opinion/commentary/">Commentary</a></li>
	<li id="menu-item-92378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92378"><a href="https://mountainx.com/opinion/humor/">Humor</a></li>
	<li id="menu-item-381353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-381353"><a href="https://mountainx.com/opinion/letters/">Letters</a></li>
	<li id="menu-item-411995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-411995"><a href="https://mountainx.com/submit-letters/">Submit Letters</a></li>
</ul>
</li>
<li id="menu-item-multimedia" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-387314 dropdown"><a href="https://mountainx.com/multimedia/" data-hover="dropdown" data-toggle="dropdown" class="mx-menu-item dropdown-toggle">Multimedia</a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-408080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-408080"><a href="https://mountainx.com/multimedia/audio/">Audio</a></li>
	<li id="menu-item-387315" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-387315"><a href="https://mountainx.com/multimedia/photos/">Photos</a></li>
	<li id="menu-item-387316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-387316"><a href="https://mountainx.com/multimedia/video/">Video</a></li>
</ul>
</li>
<li id="menu-item-548785" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-548785"><a href="https://mountainx.com/contact/">Contact</a></li>
</ul>			</div>
			
			<div id="mx-nav-account" class="collapse navbar-collapse navbar-left">
				<ul class="nav navbar-nav visible-xs">
      				<li><a data-toggle="modal" data-target="#loginModal" href="https://mountainx.com/wp-admin/admin-ajax.php?action=load_login_modal">Log in</a></li>
      				<li><a href="https://mountainx.com/wp-login.php?action=register">Register</a></li>
				</ul>
			</div>
			
			<button type="button" class="navbar-toggle visible-sm" data-toggle="collapse" data-target="#mx-nav-search-sm"><i class="fa fa-search"></i></button>
			
			<div id="mx-nav-search" class="collapse navbar-collapse navbar-right">
				<div id="mx-nav-search-sm" class="collapse">
					<form method="get" class="navbar-form" role="search" action="https://mountainx.com/">
						<div class="form-group">
							<input type="search" id="mx-search-box" name="s" value="" class="form-control" placeholder="Search Xpress">
													</div>
					</form>
				</div>
			</div>
		</div>
	</div>
	
	<div id="mx-content">
	
	<!-- Ads Takeover -->
	<div id="mx-ad-takeover-left" class="visible-md visible-lg" style="width:400px;height:900px;">
	<script type='text/javascript'>
		googletag.cmd.push(function() { googletag.display('mx-ad-takeover-left'); });
	</script>
	</div>
	<div id="mx-ad-takeover-right" class="visible-md visible-lg" style="width:400px;height:900px;">
	<script type='text/javascript'>
		googletag.cmd.push(function() { googletag.display('mx-ad-takeover-right'); });
	</script>
	</div>	
	
	<div id="mx-pencil-container" class="container">
		<!-- Ad Pencil -->
		<div id="mx-ad-pencil" class="visible-md visible-lg">
		<script type='text/javascript'>
			googletag.cmd.push(function() { googletag.display('mx-ad-pencil'); });
		</script>
		</div>
	</div>
	
	<!-- Ad Mobile Takeover -->
	<div id="mx-ad-mobile-takeover" class="visible-xs" style="width:320px;height:60px;">
	<script type='text/javascript'>
		googletag.cmd.push(function() { googletag.display('mx-ad-mobile-takeover'); });
	</script>
	<div id="mx-ad-mobile-takeover-swipe" class="hidden"><div><i class="fa fa-hand-o-left"></i> Swipe</div></div>
	</div>
	
	<!-- Ad Mobile Takeover Fullscreen -->
	<div id="mx-ad-mobile-takeover-fullscreen" class="hidden">
	<script type='text/javascript'>
		googletag.cmd.push(function() { googletag.display('mx-ad-mobile-takeover-fullscreen'); });
	</script>
	<div id="mx-ad-mobile-takeover-fullscreen-close"><div class="close-box"><i class="fa fa-times"></i> Close</div></div>
	</div>
	
	<!-- Ad Mobile Leaderboard -->
	<div id="mx-ad-mobile-leaderboard" class="visible-xs" style="width:320px;height:100px;">
	<script type='text/javascript'>
		googletag.cmd.push(function() { googletag.display('mx-ad-mobile-leaderboard'); });
	</script>
	</div>
<div class="container-fluid">
<div class="row">
	<div id="primary" class="content-area col-md-8 col-lg-8">
		<main id="main" class="site-main" role="main">
		
		<!-- dj include 11/08/17 to show author metadata -->
		
			<div class="modal fade" id="imgModal">
	<div class="modal-dialog modal-lg">
		<div class="modal-content">
			<div class="modal-header">
				<button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
				<h3 class="modal-title">&nbsp;</h3>
			</div>
			<div class="modal-body"></div>
			<div class="modal-footer"></div>
		</div>
	</div>
</div>
<article id="post-733463" class="mx-single post-733463 mx_blogwire type-mx_blogwire status-publish hentry category-business category-community-news category-news tag-ashevilledowntownassociation tag-cleanup-day tag-downtown-2">
	<header class="entry-header">
		<h1 class="entry-title">Asheville Downtown Association to hold cleanup day April 18</h1>
		<div class="entry-meta">
			<span class="posted-on">Posted on <a href="https://mountainx.com/blogwire/asheville-downtown-association-to-hold-cleanup-day-april-18/" title="4:36 PM" rel="bookmark"><time class="entry-date published" datetime="2019-03-19T16:36:11+00:00">March 19, 2019</time><time class="updated" datetime="2019-03-19T16:36:11+00:00">March 19, 2019</time></a></span> <span class="byline">&mdash; <span class="author vcard"><a class="url fn" href="https://mountainx.com/author/community-bulletin/" title="View all posts by Community Bulletin">Community Bulletin</a></span></span>			
		</div>
	</header>
	<div class="entry-content">
		<p><strong>Announcement from the Asheville Downtown Association:</strong></p>
<blockquote>
<table border="0" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td>The Asheville Downtown Association is partnering with Asheville GreenWorks for Downtown Clean Up Day on Thursday, April 18 as part of Earth Month. The Clean Up will occur from 11am to 1pm, headquartered in Pritchard Park.</p>
<p>Participants will be treated to a pizza lunch after their shift and have a chance to win some awesome raffle prizes.</p>
<p>On our recent <a href="https://www.ashevilledowntown.org/sites/default/files/2018%20Downtown%20Census%20PDF%20Public%20File.pdf">Downtown Census Survey</a> businesses indicated that cleanliness is a top  issue in downtown, so here’s an opportunity to be part of a solution.</p>
<p>We encourage businesses to sign up as a team, but individual volunteers are great too! We’ll partner you up with a group. All supplies will be provided and we’ll assign your team an area upon check in. Let’s show downtown some love! <a href="http://report.mnb.email/t.js?s=5c913eaf1ab498158f74109a&amp;u=41319522&amp;v=3&amp;key=5d64&amp;skey=b3767de149&amp;url=https%3A%2F%2F2019downtowncleanupday.eventbrite.com" target="_blank" rel="noopener">Register here.</a></td>
</tr>
</tbody>
</table>
</blockquote>
			</div>
	
	<footer class="entry-meta-links clearfix">
<a id='post-likes' data-post-id='733463' data-user-id='0'><span class='label mx-bg-views'><i class='fa fa-heart-o'></i> <span class='count'> like</span></span></a><a><span class='label mx-bg-views'>39 views</span></a><a href='https://mountainx.com/news/business/' rel='category tag'><span class='label mx-bg-news'>Business</span></a><a href='https://mountainx.com/news/community-news/' rel='category tag'><span class='label mx-bg-news'>Community News</span></a><a href='https://mountainx.com/news/' rel='category tag'><span class='label mx-bg-news'>News</span></a><a href='https://mountainx.com/tag/ashevilledowntownassociation' rel='tag'><span class='label mx-bg-light'>Asheville Downtown Association</span></a><a href='https://mountainx.com/tag/cleanup-day' rel='tag'><span class='label mx-bg-light'>cleanup day</span></a><a href='https://mountainx.com/tag/downtown-2' rel='tag'><span class='label mx-bg-light'>downtown</span></a>	</footer>
	<div id="sharebar">
		<small>SHARE</small>
		<a class="expand mx-bg-primary" onclick="maximizeShareBar()"><i class="fa fa-plus"></i></a>
		<a class="share social-facebook" onclick="shareFacebook()"><i class="fa fa-facebook"></i></a>
		<a class="share social-twitter" onclick="shareTwitter('avlnews')"><i class="fa fa-twitter"></i></a>
		<a class="share social-google-plus" onclick="shareGooglePlus()"><i class="fa fa-google-plus"></i></a>
		<a class="share mx-bg-default" onclick="shareEmail()"><i class="fa fa-envelope-o"></i></a>
		<a class="share mx-bg-light" onclick="window.print();return false;"><i class="fa fa-print"></i></a>
	</div>
	<script>initSocialJS();</script>
</article>
<script>loadLikeButton();loadMobilePremiumBoxAd();loadPremiumBannerAd(0);</script>			
			<div id="author" class="author-meta"><div class="author-avatar pull-left"><img alt='' src='https://secure.gravatar.com/avatar/a9724b5118bdb9b651fa6cc4af98f30e?s=80&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/a9724b5118bdb9b651fa6cc4af98f30e?s=160&#038;d=retro&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /></div><div class="author-about"><h5>About Community Bulletin</h5></div><div class="author-bio"><i>Mountain Xpress<i /> posts selected news and information of local interest as a public service for our readers. To submit press releases and other community material for possible publication, email <a href="mailto:news@mountainx.com">news@mountainx.com</a>.</div><div class="author-vcard clearfix"><a href="https://mountainx.com/author/community-bulletin/" title="Community Bulletin">View all posts by Community Bulletin &rarr;</a></div></div>			
				<nav role="navigation" id="post-pager" class="post-navigation">

		
	<div class="mx-pager">
		<a href="https://mountainx.com/blogwire/health-insurance-industry-critic-wendell-potter-to-speak-in-asheville-april-10/" rel="prev"><div><span class="fa fa-chevron-left"></span> Older Post</div><strong>Health insurance industry critic Wendell Potter to speak in Asheville April 10</strong></a>			</div>

	
	</nav><!-- #post-pager -->
				<!-- end dj include -->
			
<div class="warning-commenter"><p><strong>Before you comment</strong></p>
<p>The comments section is here to provide a platform for civil dialogue on the issues we face together as a local community. Xpress is committed to offering this platform for all voices, but when the tone of the discussion gets nasty or strays off topic, we believe many people choose not to participate. Xpress editors are determined to moderate comments to ensure a constructive interchange is maintained. All comments judged not to be in keeping with the spirit of civil discourse will be removed and repeat violators will be banned. See here for our <a href="http://mountainx.com/terms/" target="_blank">terms</a> of service. Thank you for being part of this effort to promote respectful discussion.</p></div>			
			
	<div id="comments" class="comments-area" style="position:static">

	
	
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blogwire/asheville-downtown-association-to-hold-cleanup-day-april-18/#respond" style="display:none;"><span class='label mx-bg-default pull-right'>&times;</span></a></small></h3>			<form action="https://mountainx.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<div class="row"><div class="col-sm-6"><div class="well well-sm comment-notes">To leave a reply you may <a href="https://mountainx.com/wp-login.php?redirect_to=https%3A%2F%2Fmountainx.com%2Fblogwire%2Fasheville-downtown-association-to-hold-cleanup-day-april-18%2F">Login</a> with your <i>Mountain Xpress</i> account, connect socially or enter your name and e-mail. Your e-mail address will not be published. All fields are required.</div></div><div class="form-group comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="06c9c-comment" class="form-control" rows="5" required="required" aria-required="true" data-toggle="popover" data-placement="top" data-content="Have your say!"></textarea><textarea name="comment" style="display:none" rows="1" cols="1"></textarea></div><div class="col-sm-6">			<div class="social_connect_ui ">
			<p class="comment-form-social-connect">
							<label>Or login with Facebook, Google or Yahoo!</label>
						<div class="social_connect_form">
							<a href="javascript:void(0);" title="Facebook" class="social_connect_login_facebook"><img alt="Facebook" src="https://mountainx.com/wp-content/plugins/social-connect/media/img/facebook_32.png" /></a>								<a href="javascript:void(0);" title="Google" class="social_connect_login_google"><img alt="Google" src="https://mountainx.com/wp-content/plugins/social-connect/media/img/google_32.png" /></a>				<a href="javascript:void(0);" title="Yahoo" class="social_connect_login_yahoo"><img alt="Yahoo" src="https://mountainx.com/wp-content/plugins/social-connect/media/img/yahoo_32.png" /></a>										</div></p>
	
						<div id="social_connect_facebook_auth">
				<input type="hidden" name="client_id" value="486085331509217" />
				<input type="hidden" name="redirect_uri" value="https://mountainx.com/index.php?social-connect=facebook-callback" />
			</div>
			
			<div id="social_connect_twitter_auth"><input type="hidden" name="redirect_uri" value="https://mountainx.com/index.php?social-connect=twitter" /></div>
			<div id="social_connect_google_auth"><input type="hidden" name="redirect_uri" value="https://mountainx.com/index.php?social-connect=google" /></div>
			<div id="social_connect_yahoo_auth"><input type="hidden" name="redirect_uri" value="https://mountainx.com/index.php?social-connect=yahoo" /></div>
			<div id="social_connect_wordpress_auth"><input type="hidden" name="redirect_uri" value="https://mountainx.com/index.php?social-connect=wordpress" /></div>
		
			<div class="social_connect_wordpress_form" title="WordPress">
				<p>Enter your WordPress.com blog URL</p><br />
				<p>
					<span>http://</span><input class="wordpress_blog_url" size="15" value=""/><span>.wordpress.com</span> <br /><br />
					<a href="javascript:void(0);" class="social_connect_wordpress_proceed">Proceed</a>
				</p>
			</div>
		</div> <!-- End of social_connect_ui div -->
	</div></div><div class="row"><div class="col-sm-6"><div class="form-group comment-form-author"><label for="author_name">Name</label><input id="author_name" name="author" class="form-control" type="text" required="required" value=""></div></div>
<div class="col-sm-6"><div class="form-group comment-form-email"><label for="author_email">E-mail</label><input id="author_email" name="email" class="form-control" type="email" required="required" value=""></div></div></div>
<p class="form-submit"><input name="submit" type="submit" id="submit_comment" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='733463' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="456b756471" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="24"/></p>			</form>
			</div><!-- #respond -->
	<script>
jQuery("#submit_comment").addClass("btn mx-bg-primary");
jQuery(window).load(function() {
	jQuery('#comments').affix({ offset: { top: function () { return jQuery("#comment").position().top-400; } } });
});
jQuery('#comments').on('affixed.bs.affix', function () {
	jQuery('#comment').popover('show');
});
</script>
</div><!-- #comments -->
			
			
				</main><!-- #main -->
	</div><!-- #primary -->
	<div id="secondary" class="widget-area col-md-4 col-lg-4" role="complementary">
				<aside id="mx_ads-8" class="widget widget_ads visible-md visible-lg"><div id='mx-ad-premium-box' style='width:300px; height:250px;'>
<script type='text/javascript'>googletag.cmd.push(function() { googletag.display('mx-ad-premium-box'); });</script>
</div>
</aside><aside id="ssrp-2" class="widget ssrp"><h1 class="widget-title">You May Also Like</h1><div class="textwidget"><div class="ssrp-before"></div><div class="post-type-post"><h3 class="blogwire-title mx-bg-news">Business</h3><ul><li>
<img width="60" height="60" src="https://mountainx.com/wp-content/uploads/2019/03/News2-60x60.jpg" class="attachment-tiny size-tiny wp-post-image" alt="HOME SWEET HOME: George Morosani, the owner of Wellington Community Estates, stands at the entrance of a single-wide manufactured home. Morosani estimates that there are 2,000 people living in his park, which has more than 400 lots. Photo by David Floyd" srcset="https://mountainx.com/wp-content/uploads/2019/03/News2-60x60.jpg 60w, https://mountainx.com/wp-content/uploads/2019/03/News2-150x150.jpg 150w" sizes="(max-width: 60px) 100vw, 60px" /><h5><a href="https://mountainx.com/news/buncombe-county-considers-expanding-access-to-manufactured-homes/">Buncombe County considers expanding access to manufactured homes</a></h5>
<time><small>4 days ago</small></time>
<div class='clearfix'></div>
</li>
<li>
<img width="60" height="60" src="https://mountainx.com/wp-content/uploads/2019/03/Mission-CarePartners-changes-4-60x60.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" srcset="https://mountainx.com/wp-content/uploads/2019/03/Mission-CarePartners-changes-4-60x60.jpg 60w, https://mountainx.com/wp-content/uploads/2019/03/Mission-CarePartners-changes-4-150x150.jpg 150w" sizes="(max-width: 60px) 100vw, 60px" /><h5><a href="https://mountainx.com/news/mission-health-sale-brings-changes-to-adult-day-care-other-services/">Mission Health sale brings changes to adult day care, other services</a></h5>
<time><small>1 week ago</small></time>
<div class='clearfix'></div>
</li>
<li>
<img width="60" height="60" src="https://mountainx.com/wp-content/uploads/2019/03/Screen-Shot-2019-02-27-at-2.40.59-PM-60x60.png" class="attachment-tiny size-tiny wp-post-image" alt="" srcset="https://mountainx.com/wp-content/uploads/2019/03/Screen-Shot-2019-02-27-at-2.40.59-PM-60x60.png 60w, https://mountainx.com/wp-content/uploads/2019/03/Screen-Shot-2019-02-27-at-2.40.59-PM-150x150.png 150w" sizes="(max-width: 60px) 100vw, 60px" /><h5><a href="https://mountainx.com/news/unca-hosts-this-years-appalachian-studies-association-conference/">UNCA hosts this year’s Appalachian Studies Association conference</a></h5>
<time><small>1 week ago</small></time>
<div class='clearfix'></div>
</li>
</ul><h3 class="blogwire-title mx-bg-news">Community News</h3><ul><li>
<img width="60" height="60" src="https://mountainx.com/wp-content/uploads/2018/02/Buncombe-County-Logo-e1505837005837-60x60.png" class="attachment-tiny size-tiny wp-post-image" alt="Buncombe County logo" srcset="https://mountainx.com/wp-content/uploads/2018/02/Buncombe-County-Logo-e1505837005837-60x60.png 60w, https://mountainx.com/wp-content/uploads/2018/02/Buncombe-County-Logo-e1505837005837-150x150.png 150w, https://mountainx.com/wp-content/uploads/2018/02/Buncombe-County-Logo-e1505837005837-330x332.png 330w, https://mountainx.com/wp-content/uploads/2018/02/Buncombe-County-Logo-e1505837005837.png 574w" sizes="(max-width: 60px) 100vw, 60px" /><h5><a href="https://mountainx.com/news/county-commissioners-to-vote-on-terms-of-medic-contract/">Commissioners to vote on terms of Medic contract</a></h5>
<time><small>1 day ago</small></time>
<div class='clearfix'></div>
</li>
<li>
<img width="60" height="60" src="https://mountainx.com/wp-content/uploads/2019/02/WELL-2-60x60.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" srcset="https://mountainx.com/wp-content/uploads/2019/02/WELL-2-60x60.jpg 60w, https://mountainx.com/wp-content/uploads/2019/02/WELL-2-150x150.jpg 150w" sizes="(max-width: 60px) 100vw, 60px" /><h5><a href="https://mountainx.com/living/childrens-musical-explores-opioid-epidemic/">Children’s musical explores opioid epidemic</a></h5>
<time><small>3 days ago</small></time>
<div class='clearfix'></div>
</li>
<li>
<img width="60" height="60" src="https://mountainx.com/wp-content/uploads/2019/03/IMG_1874-60x60.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" srcset="https://mountainx.com/wp-content/uploads/2019/03/IMG_1874-60x60.jpg 60w, https://mountainx.com/wp-content/uploads/2019/03/IMG_1874-150x150.jpg 150w" sizes="(max-width: 60px) 100vw, 60px" /><h5><a href="https://mountainx.com/news/amid-soul-searching-over-severe-disparities-city-council-weighs-its-latest-school-board-appointments/">Amid soul searching over severe disparities, City Council weighs its latest school board appointments</a></h5>
<time><small>1 week ago</small></time>
<div class='clearfix'></div>
</li>
</ul><h3 class="blogwire-title mx-bg-news">News</h3><ul><li>
<img width="60" height="60" src="https://mountainx.com/wp-content/uploads/2019/03/GetImage.axd_-60x60.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" srcset="https://mountainx.com/wp-content/uploads/2019/03/GetImage.axd_-60x60.jpeg 60w, https://mountainx.com/wp-content/uploads/2019/03/GetImage.axd_-150x150.jpeg 150w" sizes="(max-width: 60px) 100vw, 60px" /><h5><a href="https://mountainx.com/news/asheville-archives-thomas-wolfe-returns-1937/">Asheville Archives: Thomas Wolfe returns for a summer in the woods</a></h5>
<time><small>8 hours ago</small></time>
<div class='clearfix'></div>
</li>
<li>
<img width="60" height="60" src="https://mountainx.com/wp-content/uploads/2019/03/IMG_1959-60x60.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Elias Varn at Asheville Youth Climate Strike" srcset="https://mountainx.com/wp-content/uploads/2019/03/IMG_1959-60x60.jpg 60w, https://mountainx.com/wp-content/uploads/2019/03/IMG_1959-150x150.jpg 150w" sizes="(max-width: 60px) 100vw, 60px" /><h5><a href="https://mountainx.com/news/asheville-students-join-in-global-youth-climate-strike/">Asheville students join in global Youth Climate Strike</a></h5>
<time><small>1 day ago</small></time>
<div class='clearfix'></div>
</li>
<li>
<img width="60" height="60" src="https://mountainx.com/wp-content/uploads/2019/03/BEAT1_Biltmore-hotel-60x60.png" class="attachment-tiny size-tiny wp-post-image" alt="Biltmore Avenue Residence Inn" srcset="https://mountainx.com/wp-content/uploads/2019/03/BEAT1_Biltmore-hotel-60x60.png 60w, https://mountainx.com/wp-content/uploads/2019/03/BEAT1_Biltmore-hotel-150x150.png 150w" sizes="(max-width: 60px) 100vw, 60px" /><h5><a href="https://mountainx.com/news/biltmore-ave-hotel-clears-council-after-earlier-opposition/">Biltmore Ave. hotel clears Council after earlier opposition</a></h5>
<time><small>6 days ago</small></time>
<div class='clearfix'></div>
</li>
</ul></div><div class="ssrp-after"></div></div></aside><aside id="mx_ads-22" class="widget widget_ads visible-md visible-lg"><div id='mx-ad-standard-box' style='width:300px; height:250px;'>
<script type='text/javascript'>googletag.cmd.push(function() { googletag.display('mx-ad-standard-box'); });</script>
</div>
</aside>	</div><!-- #secondary -->
</div><!-- .row -->
</div>
	</div><!-- #mx-content -->
</div><!-- #mx-wrap -->
<div id="footer">
	<div class="container hidden-xs">
		<div class="mx-cats">
			<ul>
<li class="cat-item cat-item-2"><a href="https://mountainx.com/arts/" title="Asheville and Western North Carolina news, reviews and previews of arts, entertainment, music, theater, literary events, visual arts &amp; dance.">Arts</a><ul class='children'><li class="cat-item cat-item-9"><a href="https://mountainx.com/arts/art-news/" >Art News</a></li><li class="cat-item cat-item-23321"><a href="https://mountainx.com/arts/comedy/" >Comedy</a></li><li class="cat-item cat-item-10"><a href="https://mountainx.com/arts/craft/" >Craft</a></li><li class="cat-item cat-item-11"><a href="https://mountainx.com/arts/dance/" >Dance</a></li><li class="cat-item cat-item-6211"><a href="https://mountainx.com/arts/fashion/" >Fashion</a></li><li class="cat-item cat-item-13"><a href="https://mountainx.com/arts/literature/" >Literature</a></li><li class="cat-item cat-item-14"><a href="https://mountainx.com/arts/music/" >Music</a></li><li class="cat-item cat-item-16"><a href="https://mountainx.com/arts/performance-art/" >Performance Art</a></li><li class="cat-item cat-item-2959"><a href="https://mountainx.com/arts/theater/" >Theater</a></li><li class="cat-item cat-item-17"><a href="https://mountainx.com/arts/visual-art/" >Visual Art</a></li></ul></li><li class="cat-item cat-item-3"><a href="https://mountainx.com/food/" title="Local food and beer news, local beer culture; restaurant and bar news, tailgate markets info, new businesses and openings, eating healthy.">Food</a><ul class='children'><li class="cat-item cat-item-18"><a href="https://mountainx.com/food/beer/" >Beer</a></li><li class="cat-item cat-item-19"><a href="https://mountainx.com/food/coffee-tea/" >Coffee &amp; Tea</a></li><li class="cat-item cat-item-21"><a href="https://mountainx.com/food/food-news/" >Food News</a></li><li class="cat-item cat-item-20"><a href="https://mountainx.com/food/wine-spirits/" >Wine &amp; Spirits</a></li></ul></li><li class="cat-item cat-item-4"><a href="https://mountainx.com/living/" title="Health and wellness news and opinion, spirituality, farming and gardening news.">Living</a><ul class='children'><li class="cat-item cat-item-46129"><a href="https://mountainx.com/living/animals/" >Animals</a></li><li class="cat-item cat-item-6138"><a href="https://mountainx.com/living/farm-garden/" >Farm &amp; Garden</a></li><li class="cat-item cat-item-19218"><a href="https://mountainx.com/living/outdoors/" >Outdoors</a></li><li class="cat-item cat-item-23"><a href="https://mountainx.com/living/spirituality/" >Spirituality</a></li><li class="cat-item cat-item-26274"><a href="https://mountainx.com/living/sports/" >Sports</a></li><li class="cat-item cat-item-23141"><a href="https://mountainx.com/living/sustainability/" >Sustainability</a></li><li class="cat-item cat-item-537"><a href="https://mountainx.com/living/wellness/" >Wellness</a></li></ul></li><li class="cat-item cat-item-5"><a href="https://mountainx.com/movies/" title="Movie reviews and movie news by Cranke Hanke.">Movies</a><ul class='children'><li class="cat-item cat-item-25"><a href="https://mountainx.com/movies/movie-news-previews/" >Movie News &amp; Previews</a></li></ul></li><li class="cat-item cat-item-6"><a href="https://mountainx.com/multimedia/" title="Video, photos, podcasts and more covering Asheville and Western North Carolina.">Multimedia</a><ul class='children'><li class="cat-item cat-item-26"><a href="https://mountainx.com/multimedia/audio/" >Audio</a></li><li class="cat-item cat-item-28"><a href="https://mountainx.com/multimedia/photos/" >Photos</a></li><li class="cat-item cat-item-27"><a href="https://mountainx.com/multimedia/video/" >Video</a></li></ul></li><li class="cat-item cat-item-7"><a href="https://mountainx.com/news/" title="Asheville and Western North Carolina news, investigative reporting, city and county government news.">News</a><ul class='children'><li class="cat-item cat-item-30"><a href="https://mountainx.com/news/business/" >Business</a></li><li class="cat-item cat-item-29"><a href="https://mountainx.com/news/community-news/" >Community News</a></li><li class="cat-item cat-item-26275"><a href="https://mountainx.com/news/education/" >Education</a></li><li class="cat-item cat-item-31"><a href="https://mountainx.com/news/environment/" >Environment</a></li><li class="cat-item cat-item-39615"><a href="https://mountainx.com/news/history/" >History</a></li><li class="cat-item cat-item-32"><a href="https://mountainx.com/news/local-government/" >Local Government</a></li><li class="cat-item cat-item-26276"><a href="https://mountainx.com/news/nonprofits/" >Nonprofits</a></li><li class="cat-item cat-item-33"><a href="https://mountainx.com/news/politics-elections/" >Politics &amp; Elections</a></li><li class="cat-item cat-item-41883"><a href="https://mountainx.com/news/tourism/" >tourism</a></li></ul></li><li class="cat-item cat-item-8"><a href="https://mountainx.com/opinion/" title="Letters to the editor, commentaries, columns and reader opinions from the Asheville area.">Opinion</a><ul class='children'><li class="cat-item cat-item-34"><a href="https://mountainx.com/opinion/commentary/" >Commentary</a></li><li class="cat-item cat-item-35"><a href="https://mountainx.com/opinion/humor/" >Humor</a></li><li class="cat-item cat-item-10067"><a href="https://mountainx.com/opinion/letters/" >Letters</a></li></ul></li>			</ul>
		</div>
	</div>
	<div class="container">
		<div class="row">
			<div class="col-md-4 col-sm-6 col-xs-12 hidden-xs">
				<div class="mx-extra">
					<h4 class="mx-footer-title" style="margin-top:0px;">More Xpress</h4>
					<ul>
						<li><a href="https://mountainx.com/classifieds/"><i class="fa fa-star-o category-living-text"></i>Classifieds</a></li>
						<li><a href="https://mountainx.com/calendar/"><i class="fa fa-calendar category-calendar-text"></i>Calendar</a></li>
						<li><a href="https://mountainx.com/clubland/"><i class="fa fa-music category-clubland-text"></i>Clubland</a></li>
						<li><a href="https://mountainx.com/ontap/"><i class="fa fa-beer category-living-text"></i>OnTap</a></li>
						
					</ul>
					<ul>
						<li><a href="https://mountainx.com/issues/"><i class="fa fa-book category-opinion-text"></i>Issue Archive</a></li>
						<li><a href="http://bestofwnc.com/" target="_blank"><i class="fa fa-trophy category-living-text"></i>X-Awards</a></li>
						<li><a href="http://avleats.com/" target="_blank"><i class="fa fa-cutlery category-food-text"></i>Eats & Drinks</a></li>
						<li><a href="http://97.67.208.110/view/index.shtml" target="_blank"><i class="fa fa-video-camera category-main-text"></i>MX Cam</a></li>
					</ul>
				</div>
			</div>
			<div class="col-md-4 col-sm-6 col-xs-12">
				<div class="mx-social-like">
					<h4 class="mx-footer-title" style="margin-top:0px;">Follow Xpress</h4>
					<ul>
						<li class="twit"><a href="https://twitter.com/mxarts" target="_blank"><i class="fa fa-twitter-square"></i>@mxarts</a></li>
						<li class="twit"><a href="https://twitter.com/mxeat" target="_blank"><i class="fa fa-twitter-square"></i>@mxeat</a></li>
						<li class="twit"><a href="https://twitter.com/mxenv" target="_blank"><i class="fa fa-twitter-square"></i>@mxenv</a></li>
					</ul>
					<ul>
						<li class="twit"><a href="https://twitter.com/mxnews" target="_blank"><i class="fa fa-twitter-square"></i>@mxnews</a></li>
						<li class="fb"><a href="http://facebook.com/mountainx" target="_blank"><i class="fa fa-facebook-square"></i>mountainx</a></li>
						<!--<li class="gp"><a href="http://plus.google.com/112246021937247311406/posts" target="_blank"><i class="fa fa-google-plus-square"></i>mountain xpress</a></li>-->
					</ul>	
				</div>
			</div>
			
			<div class="col-md-4 col-xs-12">
				<div class="mx-email-signup">
					<h4 class="mx-footer-title">Xpress Newsletter</h4>
					<p>Subscribe to the Xpress Newsletter and get all the week's print stories delivered to your inbox!</p>
					<form method="post" action="https://mountainx.com/?na=s" onsubmit="return newsletter_check(this)">
						<input type="hidden" name=“nlang” value="widget">
						<div class="input-group">
							<input class="form-control" type="email" name="ne" placeholder="E-mail address" required>
							<span class="input-group-btn">
								<input class="btn mx-bg-default" type="submit" value="Subscribe">
							</span>
						</div>
					</form>
				</div>
			</div>
		</div>
	</div>
	<div class="navbar navbar-default" role="navigation">
		<div class="container">
			<ul class="nav navbar-nav navbar-left">
				<li><a href="/contact/"><i class="fa fa-envelope-o fa-lg"></i>Contact</a></li>
				<li><a href="/advertising/"><i class="fa fa-bullhorn fa-lg"></i>Advertise</a></li>
				<li><a href="/terms/"><i class="fa fa-umbrella fa-lg"></i>Terms &amp; Privacy</a></li>
				<li><a href="mailto:feedback@mountainx.com" class="visible-xs"><i class="fa fa-pencil fa-lg"></i>Website Feedback</a></li>
			</ul>
			<div class="pull-right stamp">
				<object type='image/svg+xml' data='https://mountainx.com/wp-content/themes/mx/img/avl-brew.svg' class='avl-brewed'></object>			</div>
			<p class="navbar-text navbar-right text-muted"><a href="/about/">Mountain Xpress</a> &copy; 1995-2019</p>
		</div>
	</div>
</div>
<link rel='stylesheet' id='mx-newsroom-style-css'  href='https://mountainx.com/wp-content/plugins/mx-newsroom/css/newsroom.css?ver=1.2' type='text/css' media='all' />
<div class="scroll-back-to-top-wrapper">
	<span class="scroll-back-to-top-inner">
					<i class="fa fa-2x fa-arrow-circle-up"></i>
			</span>
</div>	<input type="hidden" id="social_connect_login_form_uri" value="https://mountainx.com/wp-login.php" />
	<script type='text/javascript' src='https://mountainx.com/wp-content/plugins/akismet/_inc/form.js?ver=3.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"702961149.3a81a9f.c4cd83cf33704a369233e8043cc4f3b8"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mountainx.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.4.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var scrollBackToTop = {"scrollDuration":"500","fadeDuration":"0.5"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mountainx.com/wp-content/plugins/scroll-back-to-top/assets/js/scroll-back-to-top.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax = {"url":"https:\/\/mountainx.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mountainx.com/wp-content/plugins/ultimate-wp-query-search-filter/classes/scripts/uwpqsfscript.js?ver=1.0'></script>
<script type='text/javascript' src='https://mountainx.com/wp-includes/js/comment-reply.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mountainx.com/wp-content/plugins/newsletter/subscription/validate.js?ver=5.7.1'></script>
<script type='text/javascript' src='https://mountainx.com/wp-includes/js/wp-embed.js?ver=4.9.8'></script>
</body>
</html>